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PowerPoint’s Views Slide View vs. Outline View
@ Normal View Slide View displays a thumbnail of Outline View displays the text content
Pictured above, it shows the Slide/Outline Pane on the left. each slide in the presentation. of each slide; you can edit the text.
The main part of the window shows the current slide view. [ Slides \[ Outline\ [ Slides \{ Outline >
52 Slide Sorter view 4 Superior
= Shows a thumbnail image of each slide. Click and drag a 23 | 15epaicree e

slide wherever you want and the presentation will update. Text in PowerPoint 2007

— . Effects has learned new tricks.
=I| Start Slideshow P h handv f
Starts the slide show from the current slide. Useful if you : I T S5 k6 Sy eatures
are testing the animation of a slide, the current slide will i R like strikethrough and

open in full screen as if you were in the audience. PO advanced features like
character spacing control.
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The Quick Access Toolbar
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Office 2007 has dispensed with all toolbars used
in previous versions. Instead, there is a Quick
Access Toolbar which is always located at the
top of your screen which can be used to add

fvtaﬁﬁ' =9~

A table is a grid where each row and column

Adding commands is easy. You can
click the pull-down icon to the right of
the toolbar and add a common
command, as shown on the right.

You can also right-click any command
in the ribbon and click Add to Quick

Access toolbar.

O - —

In PowerPoint options, you can further

customize such that when you open a
certain presentation, a custom toolbar
will appear just for that presentation.

Inserting a Basic Table

intersects to create a cell. Information of nearly E
any type can be stored in a cell like text or Table
3x5 Table

The big advantage of a table is that you can OOOOoooO
enter in as much information as you like, and the I [
table will still keep things neat and organized on I

OOoOo0oddd
Inserting a basic table is easy. Click the Insert DDDDEEEEEE
ribbon, and then click Table. Click the lower- o0 ooooo
rightmost cell of the table size you need. o [ T o o T
At right, a 3x5 (column x row) is selected. & | Insert Table...
At far right, the table is inserted and pre- 4 | prawTable
formatted to make data easier to read. )| Excel Spreadsheet

General Font Commands

Click the pull-down arrow to choose a new font.
Choose a font size

Incrementally increases/decreases font size.
Removes any formatting applied to a font.
Makes text bold, italic, or underlined.

Draws a line through text.

Draws a shadow underneath the text.

Adjusts space between each character.

Make a selected block of text all upper or lower
case.
Change the color of the font.

Using Find and Replace

Find will search the entire presentation for an instance of a word or phrase.
Replace (commonly called Find and Replace) will search, and then
substitute any matching text with text you have specified.

(Replace @E}
Find what: ' Find Next
]
Replace with:
8
[Imatch case
[C]Find whole words only Replace Al
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Quick Print
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Note that PowerPoint has

applied some formatting

foryou.

And each alternating row is

a different color...

Decrease/increase the indent of a paragraph.
Specify the space between lines of text.

Turn the text a degree of rotation.
Change how text is aligned in the text box.
Change a list of information into a SmartArt diagram.

Aligns text to the left margin, the center of the
placeholder, or the right margin.
Aligns text to the left and right margins, equally spacing

out text.

Split a text area into two or more columns.

The Format Painter is found in the Clipboard
chunk of the Home ribbon. It allows you to
copy the formatting of a block of text rather
than copy the text itself. If you decide to make
a formatting change that has to be done on
several slides, there is no easier way!

Highlight the source text, click Format Painter,

and then highlight the target text. The

formatting will be applied. Double-clicking the

- Inserts a bulleted/numbered list

command will let you ‘paste’ the formatting over
and over until you click the command a final

time to stop.

n

ling <_

The title row is dark blue.

..making the table easier

toread

=0 %
_j%
Paste

- | F

Clipboard ™
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Table Style Options

A table can be as simple or as complex and you want to make it. Use
the Table Tools ribbon to add or remove the following style options for
the table, such as banded rows (easy to see when using a large table)

Header Row [¥] First Column
Total Row [ Last Column
Banded Rows [] Banded Columns

\ Table Style Options

| Banded Rows

Display banded rows, in which
o -0 even rows are formatted differently
2.8 | 2 B | from odd rows.
4 4
.
5

This banding can make tables
easier to read.

T O mmo o

T m

Performing Basic File Tasks

When using the My Computer dialogue box (Open & Save As
commands) you can perform basic file management tasks. Right-click
files and folders to Cut, Copy, Rename, and Delete:

Select

Open

Explore

Search...

Open as Notebook in OneNote

Sharing and Security. ..
& Snaglt >
Badd to archive...
B add to "Section 1.rar"
B Compress and email...
B Compress to "Section 1.rar" and email

\&, Groove Folder Synchronization »
Send To >
Cut )

Copy

Create Shortcut
Delete
Rename

Properties

You can also click and drag files into folders using this view. Finally,
use the My Computer toolbar at the top of the dialogue box for
navigation options:

Change
Views

!

v @-\_a xcid- |

/TN

Change locations Up one Folder

Delete
Create
Back New Folder
Inserting a Simple Table

Insert > Table, and then 3x2 Table
hover over the size of table

you want to insert. Click in I:
the lower-rightmost corner l:
of your desired table size. e

Adding a Special Character

If you are adding a mathematical equation to a slideshow, you might want to use
special symbols to enhance your content. Click Insert > Symbol to add one.

Symbol [_"JE
Tlolclolt]u|o|x|wlwli]olo]o|o|E ™
E|B|FIE|S|I|T]|J|/mBb/RIRNIVIUIA
B|IB|M|O[E[¥|[3|N|A|K|AM|H|O|N|P[E
CIT|V[@[X|UH|WWblbl|b|3[O[A]a
Recently used symbols:
nfele¥]o|o[™|+]#]s|2]+|x]lu|a]
GREEK SMALL LETTER PI Character code: 03C0 from:

The My Places Toolbar

The My Computer dialogue box contains a listing of different computer locations
on the left. Click any of these locations to be shown the contents of that folder:

D

My Recent
Documents

Deskkop

™,

My Documents

8

My Computer

My MNetwork
Places

My Recent Documents will list all of the
files, presentations etc. that have been
worked on recently. My Recent
Documents will display folders, how many
files are in the folders, and the individual
files.

This icon allows you to access all of the
items on your desktop.

My Documents is the default Windows
location for all folders and files.

My Computer gives you access to My
Documents as well as all drives in your
computer.

My Network Places will display all folders
shared by other computers. For example,
if you have a main server and have a
shared network, you can access files and
folders on the server via your workstation
computer with this shortcut.

Saving in Different File Formats

Use the Save As command - Save as type combo box to select a file type:

PowerPoint Macro-Enabled Presentation {*.pptm)
PowerPoint 97-2003 Presentation (*.ppt)

PDF (*.pdf)

¥PS Document {*.xps)

PowerPoint Template (*.potx)

© 2005 Velsoft Courseware Inc. All rights reserved.

Velsoft Quick Reference Tutorial




Adding Animations Navigating your Presentation

You can add emphasis to a presentation by animating titles, text, PowerPoint provides you with four very faint commands in the lower-left hand corner
objects, etc. Anything on a slide except for a sound clip and slide of the presentation (when viewing in full screen). Hover your mouse over each icon
background can be animated. to use

L ) Previous Slide Click this to move back one slide in the presentation.
The Custom Animation task pane lets you select an object to
animate from the slide and then choose an animation. You can Pen/Highlighter You can use a virtual marker to emphasize points about
animate objects so they appear on the slide, move in some way to your presentation. Click the command and then choose a
add emphasis, or move off the slide. You can also define a custom pen style/color. When you have completed your slide
animation path by drawing with your mouse directly on the slide: show, you have the option to save any markings you

made to the show.

“| Custom Animation v x —
T G srov
_-_*' z / Ballpoint Pen
X Entrance > T Theme Colors
# Emphasi # | EeltTip Pen
3 mphasis » N H H EENEN
X ex , # | Highlighter
— - - Ink Color 4 0
Yy Motion Paths » | \ 1. Diagonal Down Right | — ]
' /  2.Diagonal Up Right : i ) . I I I I I I I
Selact an elemer | 3.Down === T Standard Colors
click "Add Effect = o en Arrow Options " Hl UEEEEE
— 5.Right Slide Show Menu Click this command to see options about your show
| &up (also accessible by right-clicking any slide):
N\ Draw Custom Path » |\ Line . : i
= Next Slide Click to advance to the next slide. You can also
More Motion Paths... . Curve advance to the next slide by clicking on an empty area of
(5 Ereeform the slide, pressing the right or down arrows, or pressing
Enter.
"’& Scribble

Adding Movies and Sounds Creating SmartArt

You can add a sound file, play a movie clip, or play a CD audio track | SmartArt is a special type of diagram designed to show a flow-through or hierarchical
when giving a presentation. Click Insert > Media Clip. You can also | model. On the Insert ribbon, click the SmartArt command. Choose a category,
click the Media Clip icon in the text placeholder: choose a style and click OK to insert.

Choose a SmartArt Graphic W

B

i n Al . - =
@ 8= List saa U0 gae @j—

222 Process

Cyde 'aﬂ-ooe o s e

Hierarchy

: ; ; ; &
When you add a clip, you will be prompted if you want to play the clip
automatically or when clicked. Relationship PR — § v_:i

Matrix

1l

Staggered Process

If you click Insert > Sound - Record Sound, use a microphone to A Pyramid =

= | — || — —— | Use to show a downward progression
H 1 1 . - ] through stages. Each of the first five
record your voice to use when narrating an automated presentation. = —*] e tert oot eomons vt 2
rectangle. Unused text does not
-" “ appear, but remains available if you
Record Sound K< (=0 BT E_EE switch layouts.
— -
Name:  Recorded Sound
;otal SOL‘Ind length: 0 ‘ - —_ 9o M
> (=]

You can also insert SmartArt by clicking the icon in a content placeholder:
Sound and video clips contain similar options which let you loop the

clip, play full screen (movie), and adjust the show volume. l
‘@DH Hide During Show \il; Play Sound: | When Clicked v hl J P;
Slide Show | [T Loop Until Stopped < Max Sound File Size (KB): 100 3 | Insert Smartart Graphic
Volume v
Sound Options {F]
Setting Auto Recover Interval Working with Text Boxes
PowerPoint can automatically save your file on regular intervals. Text Box manipulation is easy — °
Adjust this property in PowerPoint Options > Save first select the text box by clicking ? . ?
_ its border. Now you can move, ; Working with Text Boxes
Save AutoRecover information every 10 3] minutes <= | Tresize, delete, rotate (green /

handle) and customize the look.
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PowerPoint Viewer 2007

If you plan to take your presentation on the road to a computer
that does not have PowerPoint installed, you can download

and use the PowerPoint Viewer.

1. Visit http://office.microsoft.com
2. Use the Search tool to find “PowerPoint Viewer”

3. Download and install the software on the
destination computer.

4. Open the program by clicking Start > All
Programs > Microsoft PowerPoint Viewer 2007.

5. Browse your computer for any PowerPoint files
and click Open to view them.

6. Proceed through the slide show by clicking,
pressing Enter, or using the right arrow on the
keyboard.

7. When the show is over, you will see the following

End of slide show, click to exit.

Once you end the show, you will be prompted to
open another file if you wish.

PowerPoint 2007 Options

Open PowerPoint options by clicking Office Menu >

PowerPoint Options. Choose a category from the list on the
left, then modify the options in the main part of the window.

Popular The Popular options are those that you
will use the most when modifying
PowerPoint. Change the color
scheme, change your user name, show

the Developer Ribbon.

Modify the way that PowerPoint will
correct mistakes you have made and
adjust other formatting and
grammatical options. Click
AutoCorrect Options to modify these
options and more.

Save Choose the default file format for
PowerPoint, set the interval when
AutoRecover will save your work for
you, store files in a temporary filer until
you are ready to publish, and more.

Modify other misc. options with this tab.
Set display options like making the
ruler visible, adjust options to print your
file, adjust how your computer behaves
during a presentation, and more.

Add and remove commands from the
Quick Access toolbar with this tab.

Manage any third-party software that is
compatible with PowerPoint.

Trust Center This tab contains information and
options relating to your personal
information and privacy when using
Microsoft software and services.

This tab offers a portal to get updates
for PowerPoint, run a diagnostic check,
activate your copy of Office 2007, etc.

Proofing

Advanced

Customize

Add-Ins

Resources

'Linking and Embedding Files

PowerPoint lets you link (add content via a hyperlink connection to a file) or embed
(inserting a foreign file type) a file in your presentation. Linking means a smaller file
size, but if the presentation is moved you will have to re-establish links to make the
content work. Embedding means adding a foreign file type to your PowerPoint
presentation. This method lets you take supplementary information with the
presentation, but at a cost of large file sizes.

To link, copy the source information and click Paste > Paste Special. When inserting
an object, click Insert > Object. Both dialogue boxes look basically the same:

Source: Microsoft Office Word Document
C:\Docume...

(®) Paste
(O Paste link

e
Picture {Enhanced Metafile)
Picture {Windows Metafile)
Formatted Text (RTF)
Unformatted Text

When linking, you can paste the information from the source file, such as text from a
Word document, or paste a link to the source file. When embedding, you can create a
new file type (and choose from a list, like above) or create from file. Creating from a file
essentially means inserting a file directly into the presentation. If the PowerPoint file
was 100KB, and a 500KB Excel spreadsheet was added, the PowerPoint file would
swell to 600KB to incorporate the Excel file completely.

\Add a Photo Album to a Presentation

PowerPoint allows you to add a photo album to a presentation that can be used to
highlight a vacation, step-by-step visual instruction, or anywhere where structured
visuals might be helpful. Click Insert - Photo Album to add content:

| Photo Album

Album Content

Insert picture from: Pictures in album: Preview:
Add more pictures File/Disk... 1 Blue hills

Winter

Insert text: 2 ;ext Btox
unse!
Add a text box hew Text Box 3 Water lilies

Text Box
Picture Options:
Captions below ALL pictures
[T ALL pictures black and white

Add captions
Adjust picture location

Choose 1,2, 0r 4

aaEC

Album Layout Image adjustment tools
Picture layout: | 2 pictures [v]
Frame shape:  Simple Frame, Black \v\ - -

Theme: / C:\Program Files\Microsoft Of "

Add style elements

. *.
Click to insert
content into show

After clicking Create, the content will be added to the current slide show. Each caption
and text box (if you chose to add them) will be positioned in the place you specified.
Each of the text boxes is a placeholder though, so you can customize each individually,
delete some of them, and move them around.

Once you are happy with the layout and content if the slide show, you can take the
presentation one step further by adding voice narration, automate the show, or package
the presentation to a CD for distribution.

© 2005 Velsoft Courseware Inc. All rights reserved.
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Types of Master Pages

A master can be one of three things: a slide, a note, or a handout. A master
is like an ‘internal’ template; that is all slides, notes, and handouts created in
the presentation will contain the same formatting as the respective master.

Notes Master Handout Master

I /672006 [ 6672006

Slide Master

+ Click to edit Master text styles
- Second level
* Third level
« Fourth level
» Fim vl

Custom Slide Shows

Imagine you have created a presentation to give to two different department
heads. Some of the information is the same for both executives, but some
information only concerns one executive. You can create two custom
shows from the main show and use only certain slides in each presentation.

Click Slide Show > Custom Slide Show, click New, and choose the slides
to use from the main list. Name the presentation and save the slide outline.

Main Presentation

Management custom show

Accounting custom show

Ascountng Dlemma I

Asssunting Objactre

Editing Masters

To view a slide, note, or handout master, click View - Slide (Note/Handout)
Master. This will open an editable template for the slide, note, or handout
master. An associated ribbon will appear for each master type. Each ribbon
contains similar commands:

Notes Master

j ';j‘ﬁp E ) [V] Header [¥] Date

' "J V] Slide Image (V] Body

Page Notes Page Slide - -

Setup Orientation ~ Orientation ~ || (V] Footer ] Page Number
Page Setup Placeholders

Page Setup lets you orient and manage the master as a whole. You can add
and customize many slide masters, but only one note and handout master.
Placeholder options let you add/remove headers, footers, date/time, content,

etc if you wish.

@ Background Styles ~

Hide Background Graphics Close
Master View
Edit Theme Background ] Close

The overall theme, as well as colors and fonts of a master can be modified
however you like. Select the placeholder or master element and make the
necessary changes. You can customize the background of any master to be
colored, or include a picture or gradient. The final button will close the view
of the master editing ribbon and return you to normal view.

Voice Narration

If you plan on creating an automated presentation for kiosk usage, adding
voice narration to a slide is a useful feature. Combined with properly set up
slide timing and animations, you can create a very attractive show!

Click Slide Show = Record Narration

&)

(Record Narration

Current recording quality

£ oK J
Quality: [untitled]
Disk use: 10 kb/second

Free disk space: 30757 MB (on C:1)
Max record time: 48754 minutes

Set Microphone Level...

Change Quality...

Tip

recording quality uses more disk space. Large narrations should be linked for better

s Adjust quality settings to achieve desired sound quality and disk usage. Higher
@ performance.

[CLink narrations in: ~ C:\...}John{Deskkop), Browse...

You can adjust the microphone volume level and the sound quality from this
dialogue box. When you are happy with the settings, click OK. You will be
prompted if you want to start narration from the beginning of the show or the
current slide.

The slide show will begin, speak whatever narration you want to say for each
slide and then click, press Enter, or press the right arrow key to advance to
the next slide.

Repeat until you have finished the presentation, then press Escape. The
slide timings and narration files will be saved with the presentation (unless
Link is checked in the above diagram).
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SharePoint Site Requirements

IE6.0 or later, SharePoint is built on Microsoft technology so

Internet IE browser will give the best support. A high-

connection speed Internet connection is strongly
recommended.

Login Info A user name and password will be provided to
you from your system administrator. Keep your
password in a safe place.

System Your computer must have Windows

2000/XP/Vista installed, and at least 512
megabytes of memory (1 gigabyte for Vista).
The recommended amount of hard drive space
depends on how much data you intend to
transfer to and from the SharePoint site.

Requirements

Smart Tags

A Smart Tag is a feature built into the Office family of program that is
designed to recognize special types of data. Smart Tags can
recognize measurements, dates, financial symbols, and the names of
people who are in your Outlook address book.

Enable Smart Tags by opening PowerPoint Options in Proofing >
Auto Correct Options - Smart Tags tab:

Bx]

(AutoCorrect

| AutoCorrect | AutoFormat As You Type ’ Smart Tags

Creating a Macro

Click Developer - Macros. Give the macro a name (description optional) and
click Create:

= — & 0 es
= ? ! ‘ A Rl ﬂ | & | & Properties
Visual Macros Macro || 7 @ B EB & 3% | G View Code
Basic A Security
Cdde Controls
=
Macro D?
Macro name: Run
My Macro
Step Into
Edit
—
Delete

Basics of the Visual Basic Editor

Open the PowerPoint file you want to use a macro with. Click Developer >
Macros, give the macro a name and click Create. The Visual Basic Editor will fill
in the basic code requirements.

When you type different object identifiers, the editor will automatically suggest a
number of attributes that can be used at the present time:

# Presentation1 .pptm - Module1 (Code)
ﬂ IPicturePosition

I (General)

PowerPoint can recognize certain types of data in your presentations. For
each recognized type, there are actions you can perform with that data.

Label text with smart tags <=

Recognizers:

Measurement Converter {(Measurement Converter)
Date (Smart tag lists)

Financial Symbol (Smart tag lists)

Person Mame (Outlook e-mail recipients)

Properties...

When you type a date like April 5, 2007, PowerPoint will add a dotted
line under the text as well as show the Smart Tag button. Click this
button for extra functionality:

Date: April 5, 2007
Schedule a Meeting

Show my Calendar

Remove this Smart Tag

Smart Tag Options...

Accessing a SharePoint Workspace

All SharePoint sites that run on a SharePoint Server have the same
general address template.

http://sps.company.com will access the main page

http://sps.company.com:<port _num>/personal/<user>/<workspace>
will access your own page.

Sub PicturePosition()
With ActiveWindow.Selection.ShapeRange
. IncrementLeft -284.3
.IncrementTop -1584.5

End With
Aetivellindow., Se /
End 3Sub & Selection i
=& SmallScroll
&' SplitHarizontal
= | | & Splitvertical

e Top l
B View ‘
E& ViewType I

Save the file and run the macro by clicking Run - Run Sub/UserForm. If you
made any grammatical or logical errors, the macro will run until it encounters the
problem. You can then use the tools in the Debug menu to work out the problem
in the code.

< | [

Consult the Microsoft Development Network for many VBA code examples.

The Developer Tab

In order to fully use macros in PowerPoint, you need to enable the Developer tab.
Do this by clicking Office Menu - PowerPoint Options = Popular tab. In the
Popular tab, check the Show Developer Tab checkbox.

Show Developer tab in the Ribbon (i
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Publishing a Presentation

PowerPoint has the ability to publish a presentation as an HTML file that
can be viewed in the Internet. When you have completed work on a
presentation, click Office Menu > Save As. Make sure that the file type
is Web Page:

File name: | 1ntroducing PowerPoink 2007.htm
Save astype:  hiigh Paae (* e * her)
Page title: Introducing PowerPoint 2007

v
B
(o] <—

By default, the title of the Web Page will be the name of the file. You
can change the title by clicking Change Title (red arrow). The Publish
button will do the necessary conversions to the PowerPoint file and then
save it as an HTML file. The file can be viewed in most popular Web
browsers, but will have the best functionality with Internet Explorer.
PowerPoint also creates a folder containing other supporting files. This
folder must be in the same directory as the HTML file in order to
properly display your page.

& Save a copy and customize its contents

Lesson 3.1.htm
HTML Document
3KB

r\—

I'/, Lesson 3.1_files

Digital Signatures

Just as you would sign off on a document, you can sign a digital
document with a signature that identifies you as you.

The signature acts like a ‘lie detector’ which will tell the truth as long as
the document is not altered after being signed. If the document is
altered in any way, the signature will remain, but will become invalid.
Checking for invalid signatures (which PowerPoint does automatically)
helps ensure the source of a document.

@a LA

Prepare the document for distribution

I\ Properties |
=) View and edit presentation properties, |
such as Title, Author, and Keywords.

Presentationl

New

Open

2 Inspect Document

/' Check the presentation for hidden
metadata or personal information.

Encrypt Document

Increase the security of the presentation by
adding encryption.

Restrict Permission

Grant people access while restricting their  »
ability to edit, copy, and print.

| 5% Prepare »
_’ﬁ Send >

E.I:‘ Publish »

Add a Digital Signature

Ensure the integrity of the presentation by
adding an invisible digital signature.
Mark as Final

Let readers know the presentation is final
and make it read-only.

Run Compatibility Checker

Check for features not supported by earlier
versions of PowerPoint.

J Close

[ﬂ PowerPoint Options ] [X Exit PowerPoint

What is a COM Add-In?

A COM Add-In is a third-party piece of software which is designed to
give extra functionality above and beyond what PowerPoint already
offers.

View current add-ins by clicking Office Menu - PowerPoint Options >
Add-Ins.

Adding Macros to Quick AccessToolbar

You can add individual macros to the Quick Access Toolbar and run them with a
single click. Open PowerPoint Options and click the Customize tab. Choose
Macros from the list of commands to add to the toolbar and then add the macros:

[l

Customize Quick Access Toolbar: (i

For all documents (default)

=l save

¥} Undo »
) Redo

Q Web Page Preview

6815 ‘Presentationl.pptm’!PicturePosition

All macros will be displayed with the same icon as above. To avoid confusion
over multiple macros, highlight a macro in the list and click the Modify button.
You can choose from a wide range of other symbols to use for your macro:

2
Symbol:

B0 A 9 HuRca
DEEESGRARD @R «

Modify Button

@* & ‘?\f'.‘)'j\_gj s dﬁg'\l?
YRFooL9H 8 0O
BELSIOTeoOD
00000000 @ & 7 .

Restricting Permission to a Document

When employing Information Rights Management (IRM, see note below), click
Office Menu > Prepare > Restrict Permission and then select
Unrestricted/Restricted access or manage the credentials needed to view your
document:

Jj Unrestricted Access
Restricted Access

Manage Credentials

If you click Manage Credentials, you will see the Permission dialogue box
appear. Enter the names of people who have permission to your document.

[/X]

Permission

:

Enter the e-mail addresses of users in the Read and Change boxes (example:
‘someone @example.com’). Separate names with a semicolon(;). To select names
from the Address book, dlick the Read or Change button.

€ Read... I
Users with Read permission can read this presentation,
but cannot change, print or copy content.
@ change...
Users with Change permission can read, edit and save
changes to this presentation, but cannot print content.
More Options...

What is Information Rights Management?

Information Rights Management lets you control which users have access to
what in your document. Permissions to read, write, and modify a document are
controlled by a central server on your network. You can specify which users will
be able to do what with a document and register those users on the server. The
users then have to enter their credentials to the server before being given
read/write access.
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